Подбор 1С

Содержание

ZIP-архив Создание  0
 Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать архив. Создание объекта За Автоматическая архивация баз 1С с использованием Cobian Backup и VBS скриптов  8
  Клиент попросил настроить автоматическую архивацию баз 1С раз в три дня и выгрузку архивов на Dropbox и на FTP Сервер. Кроме 1С нужно архивировать папку с рабочими документами. Хочет — так хочет, делаем: Первым делом настроим автоматическую архивац   55
 Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В Ввести перечисление, выбор перечисления  1
  // В 8-ой версии нет такой фунции, но можно сделать так: ЗначПер=Перечисления.Важность.Средняя; //Установим перечисление предлагаемое выбрать по умолчанию Если ВвестиЗначение(ЗначПер,»Выберите важность:») тогда Сообщить(ЗначПер); //обработка в Ввод дополнительного ежегодного отпуска  1
 Вид расчета, используемый для начисления оплаты дополнительного ежегодного отпуска , описывается в плане видов расчета Основные начисления организаций . Новый вид расчета удобнее создать копированием предопределенного вида расчета Оплата отпуска п Посмотреть все результаты поиска похожих

Теги: 1С:Предприятие • Владелец • ОбработкаВыбора • ОповеститьОВыборе • ОткрытьФорму • УправляемаяФорма

Для иллюстрации механизма подбора информации в форме будем использовать задачу подбора элементов справочника Номенклатура в табличную часть документа ПриходнаяНакладная как наиболее распространенную. Поскольку механизм подбора реализован на уровне форм, то в других случаях просто будут задействованы иные прикладные объекты. Сама механика подбора не изменится.

Для организации подбора в форму документа следует открыть форму справочника как подчиненную форме документа в целом либо одному из элементов формы. Способ получения формы справочника может быть любым, также как и сама форма справочника, которая будет использована. Важно лишь то, что эта форма должна быть открыта как подчиненная.

Результат подбора будет доступен в обработчике события ОбработкаВыбора формы документа или элемента формы (в зависимости от того, чему мы подчиним форму справочника при открытии). Событие ОбработкаВыбора в форме документа будет вызвано в двух случаях:

  • когда в форме справочника будет выполнен интерактивный выбор;
  • когда в форме справочника будет вызван метод ОповеститьОВыборе.

Одиночный подбор

При одиночном подборе форма справочника будет закрываться сразу после выбора элемента. Для выбора следующего элемента необходимо будет снова инициировать подбор.

Откроем форму документа ПриходнаяНакладная, создадим команду Подбор и назначим для нее обработчик:

&НаКлиенте Процедура ВыборОдногоЭлемента(Команда) // Форма выбора закрывается после двойного клика // по выбранному элементу ОткрытьФорму(«Справочник.Номенклатура.ФормаВыбора»,,Элементы.Материалы); КонецПроцедуры

В этой процедуре мы открываем форму выбора для справочника Номенклатура, указывая, что она подчинена таблице Материалы формы документа ПриходнаяНакладная (Элементы.Материалы). При выборе из формы выбора справочника выбранное значение будет передано в обработчик события ОбработкаВыбора таблицы формы Материалы, так как она является владельцем открытой формы выбора.

Поэтому откроем палитру свойств таблицы Материалы и создадим обработчик события ОбработкаВыбора:

&НаКлиенте Процедура МатериалыОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка) Элементы.Материалы.ДобавитьСтроку(); Элементы.Материалы.ТекущиеДанные.Материал = ВыбранноеЗначение; КонецПроцедуры

В этой процедуре мы добавляем новую строку в таблицу Материалы и присваиваем колонке Материал в новой строке выбранное в форме выбора справочника значение. Это значение передается в обработчик события в параметре ВыбранноеЗначение.

Множественный подбор

При множественном подборе форма справочника будет открыта до тех пор, пока пользователь не закроет ее интерактивно или не будет вызван метод формы Закрыть().

Обработчик команды Подбор:

&НаКлиенте Процедура ВыборЭлементовБезЗакрытияФормы(Команда) // Не закрывать форму после двойного клика; можно выбрать // несколько элементов, дважды кликая на каждом ПараметрыФормы = Новый Структура(«ЗакрыватьПриВыборе», Ложь); ОткрытьФорму( «Справочник.Номенклатура.ФормаВыбора», ПараметрыФормы, Элементы.Материалы ); КонецПроцедуры

Обработчик события ОбработкаВыбора остается без изменений.

Подбор с использованием множественного выбора

Еще одним способом организации подбора является возможность выделения в списке сразу нескольких строк. Режим множественного выделения в списке устанавливается, как правило, во всех формах списков по умолчанию. Однако возможность выбрать сразу несколько элементов из списка по умолчанию, как правило, отключена.

Поэтому для того, чтобы в форме списка справочника Номенклатура можно было не только отметить, но и выбрать сразу несколько элементов, мы воспользуемся одним из параметров расширения формы динамического списка — МножественныйВыбор.

Обработчик команды Подбор:

&НаКлиенте Процедура МножественныйВыбор(Команда) // Позволяем выделить и выбрать несколько элементов; в обработчик // ОбработкаВыбора() передается массив элементов ПараметрыФормы = Новый Структура(«МножественныйВыбор», Истина); ОткрытьФорму( «Справочник.Номенклатура.ФормаВыбора», ПараметрыФормы, Элементы.Материалы ); КонецПроцедуры

Обработчик события ОбработкаВыбора:

&НаКлиенте Процедура МатериалыОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка) Для Каждого ВыбранныйЭлемент Из ВыбранноеЗначение Цикл НоваяСтрока = Объект.Материалы.Добавить(); НоваяСтрока.Материал = ВыбранныйЭлемент; КонецЦикла; КонецПроцедуры

Множественный подбор с использованием множественного выбора

Последний способ подбора сочетает в себе оба рассмотренных ранее способа. Мы будем отмечать сразу несколько элементов справочника и подбирать их в документ без закрытия формы выбора. Затем снова отмечать несколько элементов справочника и подбирать их в документ. Для этого нам будет необходимо при открытии формы выбора установить оба параметра: ЗакрыватьПриВыборе и МножественныйВыбор.

Обработчик команды Подбор:

&НаКлиенте Процедура МножественныйВыборБезЗакрытияФормы(Команда) // Позволяем выделить и выбрать несколько элементов несколько раз; в // обработчик ОбработкаВыбора() передается массив элементов; после // каждого выбора форма не закрывается ПараметрыФормы = Новый Структура( «ЗакрыватьПриВыборе,МножественныйВыбор», Ложь, Истина ); ОткрытьФорму( «Справочник.Номенклатура.ФормаВыбора», ПараметрыФормы, Элементы.Материалы ); КонецПроцедуры

Обработчик события ОбработкаВыбора остается без изменений.

Использование метода ОповеститьОВыборе()

Метод формы ОповеститьОВыборе() используется в тех случаях, когда алгоритм формирования данных подбора сложен и кроме собственно выбора элемента справочника от пользователя требуется указание некоторой дополнительной информации. В этом случае метод ОповеститьОВыборе() вызывается тогда, когда вся необходимая информация подбора сформирована.

Метод ОповеститьОВыборе() посылает оповещение владельцу формы о выполнении выбора или подбора, передает ему выбранное значение и закрывает форму, если она открыта не в режиме множественного выбора.

Также метод ОповеститьОВыборе() может использоваться в тех случаях, когда требуется передать в форму документа не только выбранный элемент справочника (или массив элементов), а некоторую произвольную структуру данных.

Справка

ТабличноеПоле.ДобавитьСтроку()

ТабличноеПоле.ДобавитьСтроку()

Добавляет строку в табличное поле, аналогично выполнению команды «Добавить».

  • Если табличное поле связано с таблицей или деревом значений, метод добавляет строку в таблицу или дерево значений (аналогично соответствующим методам этих объектов).
  • Если табличное поле связано со списком объектов, хранимых в базе данных, метод начинает редактирование нового объекта этого списка. (Например, список объектов в форме списка справочника, или документа).
  • Если табличное поле связано с набором записей или табличной частью, то метод начинает редактирование новой записи. (Например, список записей в форме списка регистра сведений; табличная часть документа или справочника).

Доступность: Толстый клиент.

ДанныеФормыКоллекция.Добавить()

ДанныеФормыКоллекция.Добавить()

Добавляет элемент в конец коллекции и возвращает его в качестве результата метода. Возвращаемое значение: ДанныеФормыЭлементКоллекции.

Поиск: 1С:Предприятие • Владелец • Обработка выбора • Оповестить о выборе • Открыть форму • Управляемая форма

Поиск элементов справочника по коду

У справочников в 1С есть встроенные функции для поиска в них элементов, к ним относится НайтиПоКоду, НайтиПоНаименованию и НайтиПоРеквизиту;

В данном случае рассмотрим поиск по коду. Можно использовать когда необходимо получить предопределенный элемент.

Синтаксис:

Справочники.<НазваниеСправочника>.НайтиПоКоду(<Код>, <ПоискПоПолномуКоду>, <Родитель>, <Владелец>)

Параметры:

НазваниеСправочника — наименование справочника, к примеру Сотрудники.

Код — если код является строкой то задается в кавычках.

ПоискПоПолномуКоду — По умолчанию установлен в значении Ложь. Но если установить в истину то поиск будет вестись по полному коду элемента. Полный код состоит из всех кодов родителей(уровней) разделены «/». Пример: «00001/0002/0008″. (необязательный)

Родитель — Ссылка на родителя. Поиск будет вестись только по тем элементам где указан данный родитель. (необязательный)

Владелец — Ссылка на элемент владельца справочника, указанного на закладке Владельцы. (необязательный)

Результат:

Если элемент не найден возвращается ПустаяСсылка, иначе ссылка на элемент.

Если существует несколько элементов, возвращается только 1.

Если код отсутствует в справочнике, т.е. установлена длина 0, то возвращается Неопределено.

Поиск документов по штрихкоду в 1С 8

Рассмотрим подключение подсистемы штрихкодирования документов на примере подключения такого механизма в конфигурации 1С 8.2 и 8.3 Управление торговлей.

Зачем нужно штрихкодирование документов в 1С?

Штрихкодирование документов может понадобится для наведения порядка в бумажном документообороте — любому бумажному документу за считанные секунды можно найти электронный аналог в системе. Например, очень удобно когда клиенты приходят в офис с уже распечатанным заказом, в котором есть штрихкод — в этом случае обслуживание клиента занимает существенно меньше времени.

Настройка штрихкодирования документов 1С

Первый шаг к настройке штрихкодирования — создание штрихкода, хранение его в базе данных и распечатка на бумажном носителе.

Генерация штрихкода и сохранение его в 1С

Для хранения штрихкода создадим у документа новый реквизит — назовём его «штрихкод».
С генерацией нового штрихкода — немного труднее. Необходимо воспользоватся процедурой РаботаСТорговымОборудованием.СформироватьШтрихКод() из конфигурации управление торговлей, и сформировать его перед записью нового документа:

Распечатка штрихкода на печатной форме описана в отдельной статье — вывод на печатную форму штрихкода.
С установкой, хранением и распечаткой документов мы разобрались. Перейдем к другому этапу — поиск документов по штрихкоду.

Настройка поиска документа в 1С по штрихкоду

Рассмотрим поиск документа по штрихкоду из формы списка документа «Заказ покупателю».
Первым делом необходимо скопировать из других форм (например форма списка номенклатуры), отвечающие за работу с внешним оборудованием — сканером штрихкода. Вот процедуры, которые необходимо поместить в форму списка:

Процедура ВнешнееСобытие(Источник, Событие, Данные) ПолучитьСерверТО().ОбработатьВнешнееСобытие(Источник, Событие, Данные, ЭтаФорма); КонецПроцедуры Функция ПоддерживаетсяВидТО(Вид) Экспорт Результат = Ложь; Если Вид = Перечисления.ВидыТорговогоОборудования.СканерШтрихКода Тогда Результат = Истина; КонецЕсли; Возврат Результат; КонецФункции // ПоддерживаетсяВидТО() Функция СШКНоменклатура(Номенклатура, Характеристика, Серия, Качество, Единица, Количество, СШК) Экспорт Результат = Истина; Возврат Результат; КонецФункции // СШКНоменклатура() Функция СШКСерийныйНомер(Номер, СШК) Экспорт Возврат Истина; КонецФункции // СШКСерийныйНомер() Функция СШКИнформационнаяКарта(Карта, СШК) Экспорт Результат = Истина; Возврат Результат; КонецФункции // СШКИнформационнаяКарта() Функция СШКНеизвестныйКод(Штрихкод, ТипКода, СШК) Экспорт НайтиЗаказПоШтрихкоду(Штрихкод); Возврат Истина; КонецФункции // СШКНеизвестныйКод() Процедура СШКОшибка(Ошибка, Штрихкод, ТипШК, СШК) Экспорт Текст = ПолучитьСерверТО().ПолучитьТекстОшибкиСШКТО(Ошибка, Штрихкод, ТипШК); Предупреждение(Текст); КонецПроцедуры // СШКОшибка()
Обратите внимание на процедуру СШКНеизвестныйКод, если стандартные механизмы не смогли найти номенклатуру — они вернут нас в функцию «СШКНеизвестныйКод» где мы его и обработаем.
Опишем процедуру НайтиЗаказПоШтрихкоду, с помощью которой мы найдем нужный документ по штрихкоду и откроем его форму:
Процедура НайтиЗаказПоШтрихкоду(ТекШтрихкод) Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | ЗаказПокупателя.Ссылка |ИЗ | Документ.ЗаказПокупателя КАК ЗаказПокупателя |ГДЕ | ЗаказПокупателя.Штрихкод= &amp;Штрихкод»; Запрос.УстановитьПараметр(«Штрихкод», ТекШтрихкод); Результат = Запрос.Выполнить(); Если Результат.Пустой() Тогда Сообщить(«Заказ с штрихкодом » + ТекШтрихкод + » не найден»); Возврат; Иначе Выборка = Результат.Выбрать(); Выборка.Следующий(); СсылкаНаДокумент = Выборка.Ссылка; СсылкаНаДокумент.ПолучитьФорму().Открыть(); КонецЕсли; КонецПроцедуры
При выполнении данной процедуры будет происходить поиск нужного заказа по штрихкоду. Если заказ найден по штрихкоду — то система откроет заказ, не найден — сообщит об этом.

Штриходирование товаров в 1C:Предприятие Документооборот

1. Штрихкодирование документов

2. Вывод штрихкода в 1С 8.3 по шаблонам документа

3. Прочие преимущества штрихкодирования в 1С

4. Поиск по штрихкоду

5. Компонента печати штрихкода на документе

6. Подключение сканера штрихкодов для 1С

Штрихкодирование товаров — это технология нанесения графической информации (черных и белых полос либо других фигур) на поверхность, тем самым предоставляя возможность техническими средствами считывать «код». На сегодняшний день, самым популярным штриховым кодом является штрихкод EAN-13, представляющий собой одномерный тринадцатизначный код.

Система штрихкодирования предназначена для того, чтобы максимально ускорить и упростить процесс поиска файлов и документов в системе. Ведь штрихкод можно присвоить каждому документу и файлу в программе.

Штрихкодирование в 1С выполняется при помощи программного кода системы, а также специализированной компоненты (работает под ОС Windows и Linux), которая выполняет визуализацию штрихкода в изображение в форматах bmp, gif, jpeg, jpg, png, tiff, tif, wmf, emf, pdf.

1. Штрихкодирование документов

Для включения возможности использования штрихкодов, необходимо установить флаг: Настройка и администрирование → Настройка программы → Делопроизводство → Штрихкодирование документов.

После включения штрихкодирования в 1С появляется возможность настроить сканер, в том числе указать ⅭOM-порт, скорость и другие параметры.

В системе документооборота СЭД предусмотрены несколько вариантов организации штрихкодирования, каждый из которых будет описан подробно.

Совершенно необязательно печатать документ из «1С:Документооборота ПРОФ». Документ уже может быть у вас на руках, а распечатывать его повторно — это трата бумаги и времени. Более того, документ может быть уже подписан. Тогда его повторная распечатка невозможна. Для этого необходимо выбрать в меню документа «Печать» пункт «Регистрационный штамп» или «штрихкод на наклейке», или «штрихкод на странице».

Рассмотрим главные отличия пунктов меню «Печать»:

1. Пункт «Регистрационный штамп». В данном способе вывода изображения штрихкода дополнительно выводится информация о регистрационном номере и дате регистрации документа (данные с закладки «Регистрация» документа).

При изменении настроек область предпросмотра сразу показывает, как данные штрихкода будет вставлены в документ. Возможны два варианта:

■ с отображением цифр;

■ без отображения цифр.

Чтобы печатать цифры в нижней части штрихкода, необходимо установить флажок «Вставлять цифры в штрихкод». По умолчанию флажок снят и цифры печататься не будут.

Если установить флажок «Больше не показывать, сразу печатать», то выбранные настройки будут использоваться в дальнейшем автоматически.

Изображение штрихкода помещается в файл с параметром обтекания «Над текстом». При этом создается новая версия файла с комментарием Вставка штрихкода.

2. Пункт «Штрихкод на наклейке». При выводе на печать наклейки на страницу будет выведен только штрихкод. Выбрать место расположения штрихкода невозможно, так как оно не имеет значения (наклейка размещается на листе с данными вручную).

3. Пункт «Штрихкод на странице». Можно напечатать штрихкод на лист уже подписанного документа. Для того чтобы не испортить оригинал, выполняйте эту операцию только в случае полной уверенности, что вы предусмотрели все сопутствующие моменты (положение листа, ориентация листа, настройка размещения штрихкода и т. д.). Доступно из меню Печать командной панели карточки документа.

Все вышеизложенные варианты разрешают печатать штрихкод на любом бумажном носителе.

2. Вывод штрихкода в 1С 8.3 по шаблонам документа

В программе предусмотрена возможность автоматической вставки штрихкодов в 1С 8.3 в файлы, создаваемые из шаблонов.

Автоматически вставляется штрихкод в файл:

■ если файл был создан из шаблона;

■ если в шаблоне файла присутствует строка «<<ВставитьИзображениеШтрихкода>>». В этом случае изображение штрихкода заменяет собой эту строку.

3. Прочие преимущества штрихкодирования в 1С

Система документооборота СЭД также дает возможность присваивать штрихкод, который был сформирован в других системах. Они могут быть получены с документами из других программ, используемых контрагентами.

К примеру, может сложиться такая ситуация: организация получила документ, на котором уже есть изображение штрихкода.

Чтобы иметь возможность найти документ по этому штрихкоду, можно нанести сторонний штрихкод, при помощи меню «Еще» пункт «Штрихкоды — Добавить штрихкод».

После присвоения документу стороннего штрихкода, пользователь сможет начать поиск по штрихкоду.

На одном документе может быть напечатано любое количество сторонних штрихкодов.

Сторонние штрихкоды используют только для поиска документов и файлов, они не участвуют при печати и выгрузке изображения штрихкода на диск.

Если к копируемому документу прикреплен файл, в который автозаполнением был вставлен штрихкод, то при записи копии документа штрихкод в файле будет автоматически перезаполнен новым значением.

В файлы некоторых форматов автоматическая и ручная вставка штрихкода средствами системы невозможна. Для этого в группе команд Штрихкоды (меню Еще списков и карточек документов и файлов) предусмотрена команда Сохранить штрихкод.

Команда открывает стандартное окно операционной системы для указания пути сохранения изображения штрихкода. Штрихкод сохраняется на локальный диск в формате JPEG.

4. Поиск по штрихкоду

Поиск по штрихкоду возможен как в ручном, так и в автоматическом режиме.

Для ручного поиска необходимо использовать сочетание клавиш Ctrl + Shift + I. После этого откроется окно для ввода кода.

В системе может быть несколько одинаковых штрихкодов по документам. Пользователю будет предложен список всех документов на выбор. Одинаковые штрихкоды могут отображаться в системе, если документы были получены с таким же кодом от разных поставщиков.

5. Компонента печати штрихкода на документе

В программе 1С:Предприятие Документооборот предусмотрена компонента печати штрихкода на обычном листе с помощью обычного принтера. Для этого необходимо:

■ из карточки документа выполнить команду Штрихкод на странице, расположенную в группе Печать панели действий;

■ из списка документов выполнить команду Печать штрихкода на странице, расположенную в меню Еще – Штрихкоды.

Перед печатью будет предложено выбрать положение штрихкода на странице и принтер, на котором необходимо выполнить печать страницы.

Для отображения окна выбора положения штрихкода на закладке Штрихкодирование в персональных настройках программы нужно включить следующие настройки:

■ Открыть настройки при штрихкодировании – для выбора расположения штрихкода на странице во время выполнения операций Вставить штрихкод и Печать регистрационного штампа;

■ Положение штрихкода – для установки положения штрихкода по умолчанию.

6. Подключение сканера штрихкодов для 1С

Сканер штрихкодов для 1С — важнейший элемент системы, использующей штрихкодирование. Без него не будет возможности в полной мере реализовать все плюсы штрихкодирования. Для того чтобы начать работать со сканером, необходимо выполнить настройку: Персональные настройки → Штрихкодирование и нажать кнопку Подключение сканера штрихкодов.

После всего этого выбираем одну из настроек сканера.

В случае если в системе не заданы настройки, их необходимо будет создать. Для этого нужно заполнить поля, указанные на рисунке:

Под номенклатурой в 1С 8.3 подразумеваются материалы, полуфабрикаты, оборудование, услуги, возвратная тара, спецодежда и пр. Все эти данные хранятся в справочнике «Номенклатура». Попасть в него можно из раздела «Справочники», подраздел «Товары и услуги», пункт «Номенклатура»

Перед вами откроется список позиций справочника, имеющий многоуровневую иерархическую структуру.

В этой статье мы пошагово рассмотрим всю инструкцию по начальному заполнению номенклатуры в 1С 8.3 на примере

Группы номенклатуры

Наша команда предоставляет услуги по консультированию, настройке и внедрению 1С.
Связаться с нами можно по телефону +7 499 350 29 00.
Услуги и цены можно увидеть по .
Будем рады помочь Вам!

Для удобства использования этого справочника в 1С Бухгалтерия используются группы (папки). В них объединяется номенклатура, имеющая общие признаки. В каждой группе в свою очередь доступно создание подгрупп (по аналогии с файловой системой на компьютере). Количество уровней иерархии задается программистом, но изначально ограничений не предусмотрено.

Создадим новую группу. В форме списка справочника «Номенклатура» нажмите на кнопку «Создать группу».

Укажите наименование создаваемой группы. Так же можно заполнить ее вид, но не обязательно.

Как видно на рисунке ниже, созданная нами группа поместилась в «Материалы». Если ее необходимо переместить в иную группу или в корень, откройте контекстное меню и выберите пункт «Переместить в группу». Откроется окно, где будет необходимо указать новое место расположения.

Создание новой номенклатурной позиции

Перейдем к добавлению самой номенклатуры. Для этого в форме списка справочника нажмите на кнопку «Создать». Перед вами откроется карточка новой номенклатуры.

Заполните поле «Наименование». Значение в поле «Полное наименование» подставится автоматически. Обратите внимание, что полное наименование выводится в отчеты, печатные формы документов, ценники и т. п. Поле «Наименование» служит для удобного поиска номенклатуры в программе.

При необходимости заполните остальные реквизиты:

  • Поля «Вид номенклатуры» и «Входит в группу» заполняются автоматически из данных той группы, в которой создается новая номенклатурная позиция. При необходимости их можно изменить.
  • Значение в поле «Единица» является единицей хранения остатков данной номенклатуры.
  • Налоговая ставка, указанная в реквизите «% НДС» при необходимости может быть изменена уже при формировании документов.
  • «Цена продажи» по умолчанию указывается в документах продажи. Данную настройку можно изменить, нажав на гиперссылку «?» рядом с данным полем.
  • В разделе «Производство» можно указать статью затрат данной номенклатурной позиции, и ее спецификацию (для готовой продукции), проще говоря состав.
  • В зависимости от особенностей номенклатуры, заполняются остальные разделы, такие как «Алкогольная продукция» и «Импортный товар».

После того, как вы заполнили карточку создаваемой номенклатуры, ее нужно записать.

Что такое вид номенклатуры в 1С 8.3 и как их настроить

Для того чтобы настроить виды номенклатуры, нажмите на соответствующую гиперссылку в форме списка справочника «Номенклатура».

Виды номенклатуры необходимы для разделения номенклатурных позиций. Каждому виду можно задать свой счет учета номенклатуры. Очень важно не допускать наличие дублей в данном справочнике, что может привести к неправильной работе счетов учета номенклатуры.

При установке типовой конфигурации от поставщика, данный справочник будет уже заполнен основными видами номенклатуры. Если вид номенклатуры является услугой, не забывайте проставлять соответствующий флаг при его создании.

Счета учета номенклатуры в 1С 8.3

Для формирования бухгалтерских проводок необходимо настроить счета учета. Сделать это можно из формы списка справочника «Номенклатура», перейдя по гиперссылке «Счета учета номенклатуры».

В стандартной конфигурации 1С Бухгалтерия 3.0 данный регистр уже заполнен. Но при необходимости его можно скорректировать вручную.

Счета учета можно настроить:

  • по конкретной номенклатурной позиции;
  • по номенклатурной группе;
  • по виду номенклатуры;
  • по складу;
  • по типу склада;
  • по организации;
  • по всей номенклатуре, указав в качестве значения, пустую ссылку.

Если для конкретной номенклатуры и для ее номенклатурной группы были настроены разные счета учета, то счет будет браться из номенклатуры. В таких случаях укрупненные счета имеют меньший приоритет.

Установка цен номенклатуры

У одной номенклатуры может быть несколько цен. Они различаются типами, например, оптовая цена, розничная цена и т. п.

Зайдите в карточку элемента справочника «Номенклатура» и перейдите по гиперссылке «Цены».

Перед вами откроется список, в котором можно установить цену для конкретного типа на определенную дату. Достаточно указать цену в соответствующей колонке, после чего нажать на кнопку «Записать цены». Документ установки цен номенклатуры будет создан автоматически, и ссылку на него вы увидите в данном списке.

Смотрите также видео про номенклатуру:

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *